User entered histor...
 
Notifications
Clear all

User entered historic data columns don't export/import properly

13 Posts
3 Users
0 Likes
210 Views
(@jkandell)
Eminent Member Customer
Joined: 2 years ago
Posts: 15
Topic starter  

When importing exported file in 2.7.1, the two added historic data columns don't quite come in properly

1) The historic sequence data table column name is blank after the transfer

2) The data itself is missing 2022's entries in both columns.


   
ReplyQuote
(@jkandell)
Eminent Member Customer
Joined: 2 years ago
Posts: 15
Topic starter  

Screen shot attached

This post was modified 8 months ago 2 times by Jonathan Kandell

   
ReplyQuote
(@jkandell)
Eminent Member Customer
Joined: 2 years ago
Posts: 15
Topic starter  

Also the standard deviation doesn't carry over for entered historical series between exporing v2.6 into v2.71 Spaces are blank. Screenshot attached.

This post was modified 8 months ago 3 times by Jonathan Kandell

   
ReplyQuote
(@smatthews51)
Member Admin
Joined: 3 years ago
Posts: 569
 

@jkandell Ah, I see the problem there. This will be corrected in v2.9.


   
ReplyQuote
(@smatthews51)
Member Admin
Joined: 3 years ago
Posts: 569
 

@jkandell This was corrected in v2.8.

Stuart


   
ReplyQuote
(@jkandell)
Eminent Member Customer
Joined: 2 years ago
Posts: 15
Topic starter  

@smatthews51 I just exported from 2.7.1 into 2.8, and the identified issues remain illustrated in both screenshots.


   
ReplyQuote
(@bytor1943)
Eminent Member Customer
Joined: 2 years ago
Posts: 14
 

@smatthews51 - After importing data from 2.7.1 into 2.8, I attempted to Update Active Analysis for Historical Results. An 'Insufficient History' message box appeared - see the attached screenshot.


   
ReplyQuote
(@smatthews51)
Member Admin
Joined: 3 years ago
Posts: 569
 

@jkandell Did you correct the export file? The problem will persist until the data is corrected and from there forward the import should be fine.

Stuart


   
ReplyQuote
(@smatthews51)
Member Admin
Joined: 3 years ago
Posts: 569
 

@bytor1943 When I say "the problem has been corrected", that doesn't mean that missing data from an earlier import will automatically start appearing. It has to be manually entered once and included in an export file. Then, it should import correctly from that point forward.


   
ReplyQuote
(@bytor1943)
Eminent Member Customer
Joined: 2 years ago
Posts: 14
 

@smatthews51 - Is this new? I have never modified the Financial Assets / Historic Data page (see attached screenshot), and the message has not appeared with previous imports. I am using Asset Allocation Mode 2.


   
ReplyQuote
(@smatthews51)
Member Admin
Joined: 3 years ago
Posts: 569
 

@bytor1943 No, but unless I'm mistaken that's the top portion of the Mode 2 Historic Data page and none of the historic data classes have yet been associated with your stock and bond asset classes. There's a pull-down menu for the stock and bond classes that you can use to make this association (click in the historic sequence row and it will appear). Once this has been done and then included in an export file, subsequent imports should retain the values you set.

Stuart


   
ReplyQuote
(@bytor1943)
Eminent Member Customer
Joined: 2 years ago
Posts: 14
 

@smatthews51 - Setting those values corrected the issue. Thank you, Stuart.


   
ReplyQuote
(@jkandell)
Eminent Member Customer
Joined: 2 years ago
Posts: 15
Topic starter  

1) Remaining "bug" with exporting/importing historical data into v2.9.2: the data for two user selected series imports properly except for data for year 2022. It defaulted to 3% for 2022 return for the two custom assets until I corrected it. Odd.

(screenshot attached.)

2) Not sure if it's a bug or intended, but the standard deviations for custom imported series has to be reset after import on the Analysis > Run Analysis page

This post was modified 6 months ago 3 times by Jonathan Kandell

   
ReplyQuote
Share: